Psycopg 2.7.6 released

Posted by Daniele Varrazzo on November 9, 2018
Tagged as news, release

We have just released psycopg 2.7.6 package, fixing the issues found in the last months in the psycopg 2.7 version.

Summary of changes:

  • Close named cursors if exist, even if execute() wasn't called (ticket #746).
  • Fixed building on modern FreeBSD versions with Python 3.7 (ticket #755).
  • Fixed hang trying to COPY via execute() in asynchronous connections (ticket #781).
  • Fixed adaptation of arrays of empty arrays (ticket #788).
  • Fixed segfault accessing the connection.readonly and connection.deferrable attributes repeatedly (ticket #790).
  • execute_values() accepts sql.Composable objects (ticket #794).
  • errorcodes map updated to PostgreSQL 11.
  • Wheel package compiled against PostgreSQL 10.5 libpq and OpenSSL 1.0.2p.

You can install psycopg2 from PyPI or grab the new code from:

Happy hacking!